No Game Dev Today

Hey Folks! Hope everyone had a good weekend. This was our last weekend in BC with furniture, so we're enjoying things like eating at a table, and sleeping on a bed. Soon, the movers will arrive, and we're off!

Back at work, I was unfortunately mired in non-gamedev stuff today. I had a bunch of administrative stuff to take care of (e.g. taxes, moving, contracts), and then I dumped pretty much the rest of my time into solving website issues.

Some of you may have noticed the site breaking in places yesterday and today. Especially links and images. This was my fault. Sorry! I thought I was being clever by changing the settings to make URLs automatically into links for people who forget to use the BBCode tags.

Unfortunately, BBCode and this auto-linking don't play well together, resulting in double html code and broken links. I've reverted that, and things seem to be back to normal now.

Also, some of you may have noticed issues with posting or editing in the forums. It turns out there is a bug (or more accurately, overzealous setting) in the server firewall which flags legitimate posts as SQL hacking attempts. It usually happens when the post contains certain sensitive keywords.

I'm working with the site host to see if we can make this rule a bit more user-friendly. But in the meantime, we're stuck with occasional 403/Access Denied errors. Again, sorry about that!

Hopefully, we can get things resolved soon. Also hopefully, I can get back to making games someday :)