Trouble Using the Mac/OSX Version?

32 posts / 0 new
Last post
#1
Trouble Using the Mac/OSX Version?

Some users have had trouble launching the Mac version. In the past, this was typically due to Apple's Gatekeeper settings, as the game wasn't an officially-signed app.

Usually, this can be bypassed by changing OSX's Gatekeeper settings. If you click on:

Apple menu > System Preferences… > Security & Privacy > General tab

You should see a screen like this:

http://support.apple.com/kb/HT5290

Changing it to allow applications downloaded from "Anywhere," rather than just the "Mac App Store" or "Mac App Store and identified developers" usually does the trick. If not, you can also check this thread, which discusses several solutions which seem to help.

Of course, if you're still having trouble, feel free to post here or in the tech support forum for more help!

Dan Fedor - Founder, Blue Bottle Games

It's your day off, shoo, go be free and rest!

But that said, there are some issues not listed here that are in the other 0.985b bug thread(s). Do you want them reposted here, or do you just want people to start using this thread from now on?

Yeah yeah, I'm a bad vacationer :)

I wouldn't repost anything here. I can still track them in the regular posts. I mainly put this here because I had a few questions regarding the Mac version, and I realized this info wasn't easy to find anywhere.

However, you make a good point. This might confuse some folks. I think what I should probably do is to make a sticky for the Mac and Linux info, like I do on Steam forums. That way, I don't have to keep making new stickies for each version if it's just this info.

Thanks for the idea!

Dan Fedor - Founder, Blue Bottle Games

I play on steam through the mac OSX version, I just tried out the new beta and it says something about the flash player not working. I'd like to play the new version cuz I was looking forward to the new starting bonuses.

I am that low life scum that hunts down a scavenger, laughs as he tries to surrender, beats him to death with my club, and eats his gummy bears before moving onto the next sucker.

Hey Flubberj,

What is the error message exactly? Is it warning you about not being able to save games? Or is it not launching at all? Or something else?

Dan Fedor - Founder, Blue Bottle Games

It tells me that flash player quit unexpectedly. The stable version works fine. This is only for the beta. And I was able to play the last beta just fine.

I am that low life scum that hunts down a scavenger, laughs as he tries to surrender, beats him to death with my club, and eats his gummy bears before moving onto the next sucker.

Which version of OSX do you use? And does the game always quit at a certain point? (e.g. do you get to see the title screen, or does it crash before then?)

Dan Fedor - Founder, Blue Bottle Games

I use 10.7.5 and it always quits before I see the title screen. Nothing pops up but the message telling me what happened.

I am that low life scum that hunts down a scavenger, laughs as he tries to surrender, beats him to death with my club, and eats his gummy bears before moving onto the next sucker.

Is this problem only happening in v0.986b? Can you run v0.985b? And does the demo work for you (both browser and download version)?

Dan Fedor - Founder, Blue Bottle Games

I can run .985 just fine. It is only in the new version. I'll check the demos

EDIT: Yes, both demos work as well as .985

I am that low life scum that hunts down a scavenger, laughs as he tries to surrender, beats him to death with my club, and eats his gummy bears before moving onto the next sucker.

Thanks for checking those things. So far, it sounds like it might be due to me using Flash v13 to package v0.986b, while previous versions used Flash v11.2.

One thing to try is to see if you can run the latest Flash player on your machine:
http://www.adobe.com/support/flashplayer/downloads.html#fp11.9

Specifically, there is a header "Macintosh" just above three Mac player links. The third one is the same version that I used to package the build:
http://fpdownload.macromedia.com/pub/flashplayer/updaters/13/flashplayer_13_sa.dmg

If you download that player, and launch it, does it produce the same error?

One other thing: do you typically use Fullscreen when you play? If you delete your preferences file, and then try to launch v0.986b. Does that help?

Your preferences file is flixel.sol, and is located in the same directory as your save games. This link explains where those files can be found:
http://bluebottlegames.com/main/node/762

Note that each version of the game will store those files in a different folder, so you may find multiple copies of flixel.sol. E.g. one for Steam, one for bluebottlegames.com, etc.

If you delete all the flixel.sol files you can find, and then launch the Steam v0.986b, does that change anything?

Dan Fedor - Founder, Blue Bottle Games

I am running the latest version of flash

I can't install the flash version from your link (the second link you posted)

And what do you mean by fullscreen? I stretch out my window to cover the screen, but I don't play with anything except 800x450. I have occasionally opened the game with the bigger ones but I haven't played with them for more than a couple minutes.

I couldn't find my save games or my flixel.sol file from looking at that post.

I am that low life scum that hunts down a scavenger, laughs as he tries to surrender, beats him to death with my club, and eats his gummy bears before moving onto the next sucker.

I can't install the flash version from your link (the second link you posted)

That's interesting. Do you get some sort of error message when you try?

As I mentioned, that's the version (v13) that I use to package the Mac builds. So if that won't run on your machine, we may have found the source of the problem.

What happens when you try to install that flashplayer_13_sa.dmg?

Dan Fedor - Founder, Blue Bottle Games

I have flash player 13, when I attempt to install from your link I can open the disk but nothing happens when I click on the flash player inside the disk.

I am that low life scum that hunts down a scavenger, laughs as he tries to surrender, beats him to death with my club, and eats his gummy bears before moving onto the next sucker.

I'm thinking you may have the Flash v13 browser plugin installed, but the link I shared is for what Adobe calls the "stand alone player," which is a way to load SWF files without installing anything on your machine. Basically, it's a stand-alone executable version of the browser plugin.

If I download the file, open the dmg, and then double-click the .app inside, I get a warning that it's downloaded from the internet, and I'm asked if I want to continue.

If I choose to continue, the Flash Player launches. Note that you won't see anything on the screen at first, except the title bar will switch from "Finder" (or similar) to "Flash Player." You should see menu options up in the menu bar for Flash things, like loading files, "About," etc.

Is it possible that you launched the player and didn't see that bar change? (I'm also using OSX 10.7.5, for what it's worth. It's a MacBook Pro, early 2008.)

Dan Fedor - Founder, Blue Bottle Games

The bar changes, but nothing happens after that. I also have 10.7.5

I am that low life scum that hunts down a scavenger, laughs as he tries to surrender, beats him to death with my club, and eats his gummy bears before moving onto the next sucker.

For what its worth, I also have a laptop with Maverick installed and neo scavenger runs just fine. The new public demo also doesn't work.

I am that low life scum that hunts down a scavenger, laughs as he tries to surrender, beats him to death with my club, and eats his gummy bears before moving onto the next sucker.

Ok. If the bar changes and nothing happens after that, I think that's normal. So it sounds like Flash Stand Alone Player v13 works on your 10.7.5 Mac if it doesn't load any files.

Do you have both a Maverick and 10.7.5 machine? Just so I can get a better picture, could you let me know what each of these cases does?

NEO Scavenger 0.986b on Maverick: Runs? Or if not, what's the error message?
NEO Scavenger 0.987b on Maverick: Runs? Or if not, what's the error message?
NEO Scavenger 0.986b on 10.7.5: Runs? Or if not, what's the error message?
NEO Scavenger 0.987b on 10.7.5: Runs? Or if not, what's the error message?

I'm curious if we can narrow this down to an OS version or build.

Dan Fedor - Founder, Blue Bottle Games

Everything works on maverick, and nothing works on 10.7.5

I am that low life scum that hunts down a scavenger, laughs as he tries to surrender, beats him to death with my club, and eats his gummy bears before moving onto the next sucker.

Ok, thanks.

On your 10.7.5 Mac, does either 0.986 or 0.987 work if you put it on your desktop first, and then launch it?

Also, what is your Gatekeeper currently set to? (E.g. allow apps from app store, all signed apps, or all apps)

Dan Fedor - Founder, Blue Bottle Games

I use neo scavenger through steam, and I always use the desktop shortcut if that's what you're talking about. And my gatekeeper allows everything. The message it says is that flash player quit unexpectedly.

I am that low life scum that hunts down a scavenger, laughs as he tries to surrender, beats him to death with my club, and eats his gummy bears before moving onto the next sucker.

I think I'm out of ideas. The last thing I can try is to make the next build use Flash 11.2 instead of 13. It's unfortunate, since 13 may have some performance gains for some users. But if it's causing the game to crash, then it's not worth it.

Dan Fedor - Founder, Blue Bottle Games

Its fine, I just play on my laptop anyway now.

I am that low life scum that hunts down a scavenger, laughs as he tries to surrender, beats him to death with my club, and eats his gummy bears before moving onto the next sucker.

I can't run the OSX app, it says the file might be damaged or incomplete. I tried re-downloading it but it's the same.
It's the Yukon version.

Hi rivaah,

Which version of OSX do you have? And when you visit this screen in OSX, what setting is Gatekeeper set to?

http://support.apple.com/kb/HT5290

Dan Fedor - Founder, Blue Bottle Games

Hi Dan,

I'm using OSX 10.7.5, and Gatekeeper is set to "Anywhere". Sorry, I should have mentioned that in the first place!

No sweat! I just always ask to make sure.

Do any of the following tricks work?

Ctrl+click->"Open" or
Right click->"Open"

Some users have mentioned that the above methods work in conjunction with Gatekeeper set to "Anywhere."

Dan Fedor - Founder, Blue Bottle Games

Ok, choosing "Open" in the menu when right-clicking didn't help, same error. But I tried opening the application package (something like "Show contents" in the right-click menu) and in there I found a file called NEOScavenger.app, which ran just fine on double clicking. It also showed the correct icon, which the first application package didn't.

So the game is loading correctly now? If so, that's good to hear!

I'm unsure what happened there, as it sounds like you found an .app file inside the .app. Unless...is it possible you were trying to run the NEOScavenger.app.zip file originally, and hadn't extracted it first? That would explain why you found the .app inside after "Show Contents," though the error message you described doesn't seem like it would appear if trying to launch a .zip.

Dan Fedor - Founder, Blue Bottle Games

That's correct, the .app-file that runs is located inside the .app-file that was the result of de-zipping NEOScavenger.app.zip.

I.e:

NEOScavenger.app.zip
unzip --> NEOScavenger.app
show contents --> NEOScavenger.app/NEOScavenger.app

Ah, I can reproduce that issue here now. Looks like the way I'm zipping the files causes it to unpack into an intermediary archive, instead of the files I put in. I'm unsure why, but packing the folder they're in instead of the files themselves seems to work.

I'll have to make sure to do that in the future. Thanks!

Dan Fedor - Founder, Blue Bottle Games

Error #2032
File not found.

Running into this problem on the most recent stable build (v1.14) for macOS, as well as the test build (v1.15). Prior to updating I had been running version 1.04, so I tried using AppCleaner to remove all traces of the old build to see if old preferences or something were screwing up the new one. That didn't fix it. 1.04 continues to run fine.

Running macOS 10.12.6 (Beta), and Flash 25.0.0.127.

EDIT / UPDATE: Ah, okay. I mistakenly believed my problem to be different from a problem someone else described above. Opening the .app application bundle and running the "Flash Player" executable does indeed make the game run properly, albeit on top of a Terminal window.